De geschiedenis van TCP/IP

De populairste netwerkprotocol ter wereld, de TCP/IP-protocolsuite, werd ontworpen in de jaren 70 door 2 DARPA-wetenschappers—Vint Cerf en Bob Kahn, personen die het vaakst worden genoemd de vaders van het internet.

In het voorjaar van 1973 begon men met onderzoek naar betrouwbare datacommunicatie via pakketradionetwerken, nam men de geleerde lessen van het Network Control Protocol in aanmerking en creëerde men vervolgens het Transmission Control Protocol (TCP) van de volgende generatie, het standaardprotocol dat vandaag de dag op internet wordt gebruikt.

In de vroege versies van deze technologie was er slechts één kernprotocol, dat genaamd werd TCP. En sterker nog, deze letters stonden niet eens voor wat ze vandaag de dag doen Transmission Control Protocol, maar ze waren voor de Transmission Control Program. De eerste versie van deze voorloper van de moderne TCP werd geschreven in 1973, vervolgens herzien en formeel gedocumenteerd in RFC 675, Specificatie van het Internet Transmission Control Program vanaf december 1974.

Tijdens de ontwikkeling van TCP gebruikten Cerf en Kahn de concepten van CYCLADES, een Frans pakketschakelnetwerk, in 1973 ontworpen en geleid door Louis Pouzin. Het werd ontwikkeld om alternatieven voor het ARPANET-ontwerp te onderzoeken en om netwerkonderzoek in het algemeen te ondersteunen. CYCLADES was het eerste netwerk dat de hosts verantwoordelijk maakte voor de betrouwbare aflevering van data, in plaats van het netwerk zelf, met gebruik van onbetrouwbare datagrammen (Pouzin bedacht de term datagram door de woorden te combineren gegevens en Telegram) en bijbehorende end-to-end-protocolmechanismen.

TCP/IP werd het standaard internetcommunicatieprotocol waarmee digitale computers over grote afstanden kunnen communiceren. Het internet is een pakketgeschakeld netwerk, waarin informatie wordt opgedeeld in kleine pakketjes, die tegelijkertijd individueel via vele verschillende routes worden verzonden en vervolgens aan de ontvangende kant weer in elkaar worden gezet. TCP is het onderdeel dat de datapakketjes verzamelt en weer samenvoegt, terwijl IP ervoor zorgt dat de pakketjes naar de juiste bestemming worden verzonden. TCP/IP werd ontwikkeld in de jaren 70 en in 1983 aangenomen als de protocolstandaard voor ARPANET (de voorloper van het internet).

5-daagse Wireshark-training: 5-daagse training – TCP/IP Analysis and Troubleshooting with Wireshark

Wat is de huidige status van de Internet Protocol Suite (algemeen bekend als TCP/IP)?

Het is de verzameling communicatieprotocollen die wordt gebruikt voor het internet en andere vergelijkbare netwerken. Het is vernoemd naar twee van de belangrijkste protocollen daarin: het Transmission Control Protocol (TCP) en het Internet Protocol (IP), de eerste twee netwerkprotocollen die in deze standaard werden gedefinieerd. De huidige IP-netwerken vertegenwoordigen een synthese van verschillende ontwikkelingen die zich in de jaren 60 en 70 begingen te ontplooien, met name het internet en LAN's (Local Area Networks), die half tot eind jaren 80 opkwamen, samen met de komst van het World Wide Web begin jaren 90.

Het ontwerp van het netwerk omvatte de erkenning dat het alleen de functies moest bieden voor het efficiënt verzenden en routeren van verkeer tussen eindknooppunten en dat alle overige intelligentie zich aan de rand van het netwerk, in de eindknooppunten, moest bevinden. Dankzij een eenvoudig ontwerp werd het mogelijk om bijna elk netwerk op het ARPANet aan te sluiten, ongeacht hun lokale kenmerken. Een bekend Gezegde luidt dat TCP/IP, het uiteindelijke product van het werk van Cerf en Kahn, zal draaien over twee blikjes en een touwtje.

Een computer of apparaat dat een router wordt genoemd (een naam die is gewijzigd van gateway om verwarring met andere typen gateways te voorkomen) is voorzien van een interface naar elk netwerk en stuurt pakketten heen en weer tussen deze netwerken. Vereisten voor routers zijn gedefinieerd in RFC 1812.

DARPA contracteerde vervolgens BBN Technologies, Stanford University en de University College London om operationele versies van het protocol te ontwikkelen op verschillende hardwareplatformen. Er werden vier versies ontwikkeld: TCP v1, TCP v2, een opsplitsing in TCP v3 en IP v3 in het voorjaar van 1978, en vervolgens stabiliteit met TCP/IP v4—het standaardprotocol dat vandaag de dag nog steeds op het internet wordt gebruikt.

In 1975 werd een TCP/IP-communicatietest met twee netwerken uitgevoerd tussen Stanford en University College London (UCL). In november 1977 werd een TCP/IP-test met drie netwerken uitgevoerd tussen locaties in de VS, het VK en Noorwegen. Tussen 1978 en 1983 werden op verschillende onderzoeks centra diverse andere TCP/IP-prototypes ontwikkeld. De migratie van ARPANet naar TCP/IP werd officieel voltooid op 1 januari 1983, toen de nieuwe protocollen permanent werden geactiveerd.

In maart 1982 verklaarde het Amerikaanse ministerie van Defensie TCP/IP tot de standaard voor alle militaire computernetwerken. In 1985 hield de Internet Architecture Board een driedaagse werkplaats over TCP/IP voor de computerindustrie, bijgewoond door 250 vertegenwoordigers van leveranciers, die het protocol promootte en leidde tot het toenemende commerciële gebruik ervan.

De internetprotocolsuite kan, net als veel protocolsuites, worden beschouwd als een verzameling lagen. Elke laag lost een reeks problemen op met betrekking tot de transmissie van gegevens en biedt een goed gedefinieerde service aan de protocollen van de bovenste laag op basis van het gebruik van diensten van lagere lagen. Bovenste lagen staan logisch dichter bij de gebruiker en verwerken abstractere gegevens, waarbij ze vertrouwen op protocollen van lagere lagen om gegevens te vertellen naar vormen die uiteindelijk fysiek kunnen worden verzonden.

Het TCP/IP-model bestaat uit vier lagen, zoals beschreven in RFC 1122. Van laagste naar hoogste zijn dit: de Linklaag, de Internetlaag, de Transportlaag en de Applicatielaag. Opgemerkt moet worden dat dit model niet bedoeld was als een rigide referentiemodel waarin nieuwe protocollen moeten passen om als standaard te worden geaccepteerd.

Bijna alle besturingssystemen die vandaag de dag in gebruik zijn, met inbegrip van alle op consumenten gerichte systemen, bevatten een TCP/IP-implementatie.

5-daagse Wireshark-training: 5-daagse training – TCP/IP Analysis and Troubleshooting with Wireshark

Bron: 
www.history-computer.com
Encyclopædia Britannica www.britannica.com/technology/TCP-IP