La storia di TCP/IP

Il protocollo di rete più popolare al mondo, la suite di protocolli TCP/IP, è stato progettato negli anni '70 da due scienziati della DARPA — Vint Cerf e Bob Kahn, le persone più spesso definite i padri di Internet.

Nella primavera del 1973, iniziarono conducendo ricerche su comunicazioni di dati affidabili attraverso reti packet radio, tennero conto delle lezioni apprese dal Network Control Protocol e crearono quindi la nuova generazione del Transmission Control Protocol (TCP), il protocollo standard utilizzato oggi su Internet.

Nelle prime versioni di questa tecnologia, c'era un solo protocollo principale, che era stato denominato TCP. E infatti, queste lettere non significavano nemmeno quello che significano oggi Protocollo di controllo trasmissione, ma erano per i Transmission Control Program. La prima versione di questo predecessore del TCP moderno fu scritta nel 1973, poi rivista e formalmente documentata nell'RFC 675, Specificazione del Programma di Controllo della Trasmissione Internet dal dicembre 1974.

Durante lo sviluppo del TCP, Cerf e Kahn utilizzarono i concetti di CYCLADES, una rete francese a commutazione di pacchetto, progettata e diretta nel 1973 da Louis Pouzin. Fu sviluppata per esplorare alternative al progetto ARPANET e per supportare in generale la ricerca sulle reti. CYCLADES fu la prima rete a rendere gli host responsabili della consegna affidabile dei dati, anziché la rete stessa, utilizzando datagrammi inaffidabili (Pouzin coniò il termine datagramma, unendo le parole dati e Telegram) e dei relativi meccanismi di protocollo end-to-end.

TCP/IP è diventato il protocollo di comunicazione standard di Internet che consente ai computer digitali di comunicare su lunghe distanze. Internet è una rete a commutazione di pacchetto, in cui le informazioni vengono suddivise in piccoli pacchetti, inviate singolarmente attraverso molti percorsi diversi contemporaneamente e poi riassemblate all'estremità ricevente. TCP è il componente che raccoglie e riassembla i pacchetti di dati, mentre IP è responsabile di assicurarsi che i pacchetti vengano inviati alla destinazione giusta. TCP/IP è stato sviluppato negli anni '70 e adottato come standard di protocollo per ARPANET (il precursore di Internet) nel 1983.

Corso di formazione Wireshark di 5 giorni: Formazione di 5 giorni – TCP/IP Analysis and Troubleshooting with Wireshark

Qual è lo stato attuale della suite di protocolli Internet (comunemente nota come TCP/IP)?

È l'insieme dei protocolli di comunicazione utilizzati per Internet e altre reti simili. Prende il nome da due dei protocolli più importanti in esso contenuti: il Transmission Control Protocol (TCP) e l'Internet Protocol (IP), che sono stati i primi due protocolli di rete definiti in questo standard. L'odierna rete IP rappresenta una sintesi di diversi sviluppi che hanno iniziato a evolversi negli anni Sessanta e Settanta, vale a dire Internet e le LAN (Local Area Networks), emerse tra la metà e la fine degli anni Ottanta, insieme all'avvento del World Wide Web nei primi anni Novanta.

Il design della rete includeva il riconoscimento che essa dovesse fornire solo le funzioni di trasmissione efficiente e di instradamento del traffico tra i nodi terminali e che tutta l'altra intelligenza dovesse essere situata ai margini della rete, nei nodi terminali. Utilizzando un design semplice, è diventato possibile connettere quasi qualsiasi rete ad ARPANet, indipendentemente dalle loro caratteristiche locali. Un detto popolare sostiene che TCP/IP, il prodotto finale del lavoro di Cerf e Kahn, funzionerà su due barattoli di latta e uno spago.

Un computer o dispositivo chiamato router (nome modificato da gateway per evitare confusione con altri tipi di gateway) è dotato di un'interfaccia per ciascuna rete e inoltra i pacchetti da una all'altra. I requisiti per i router sono definiti nell'RFC 1812.

La DARPA ha poi stipulato contratti con BBN Technologies, la Stanford University e l'University College London per sviluppare versioni operative del protocollo su diverse piattaforme hardware. Sono state sviluppate quattro versioni: TCP v1, TCP v2, una scissione in TCP v3 e IP v3 nella primavera del 1978, e infine la stabilità con TCP/IP v4, il protocollo standard ancora oggi in uso su Internet.

Nel 1975 fu eseguito un test di comunicazione TCP/IP a due reti tra Stanford e lo University College London (UCL). Nel novembre del 1977 fu condotto un test TCP/IP a tre reti tra siti negli Stati Uniti, nel Regno Unito e in Norvegia. Diversi altri prototipi TCP/IP furono sviluppati in molteplici centri di ricerca tra il 1978 e il 1983. La migrazione di ARPANet a TCP/IP fu ufficialmente completata il 1° gennaio 1983, quando i nuovi protocolli furono attivati permanentemente.

Nel marzo 1982, il Dipartimento della Difesa degli Stati Uniti dichiarò il TCP/IP come standard per tutte le reti di computer militari. Nel 1985, l'Internet Architecture Board tenne un seminario di tre giorni sul TCP/IP per l'industria informatica, a cui parteciparono 250 rappresentanti di fornitori, promuovendo il protocollo e portando al suo crescente uso commerciale.

La suite di protocolli Internet, come molte suite di protocolli, può essere vista come un insieme di livelli. Ciascun livello risolve un insieme di problemi relativi alla trasmissione dei dati e fornisce un servizio ben definito ai protocolli dei livelli superiori basandosi sull'utilizzo dei servizi di alcuni livelli inferiori. I livelli superiori sono logicamente più vicini all'utente e gestiscono dati più astratti, affidandosi ai protocolli dei livelli inferiori per tradurre i dati in forme che possano infine essere trasmesse fisicamente.

Il modello TCP/IP è costituito da quattro strati, come descritto nella RFC 1122. Dal più basso al più alto, questi sono: il livello di collegamento, il livello Internet, il livello di trasporto e il livello applicativo. Va notato che questo modello non è stato concepito come un modello di riferimento rigido in cui i nuovi protocolli debbano inserirsi per essere accettati come standard.

Quasi tutti i sistemi operativi in uso oggi, compresi tutti i sistemi destinati ai consumatori, includono un'implementazione TCP/IP.

Corso di formazione Wireshark di 5 giorni: Formazione di 5 giorni – TCP/IP Analysis and Troubleshooting with Wireshark

Source 
www.history-computer.com
Enciclopedia Britannica www.britannica.com/technology/TCP-IP