L'histoire de TCP/IP
La suite de protocoles TCP/IP, le protocole réseau le plus populaire au monde, a été conçue dans les années 1970 par deux scientifiques de la DARPA — Vint Cerf et Bob Kahn, les personnes le plus souvent appelées les pères d'Internet.
Au printemps 1973, ils ont commencé par effectuer des recherches sur les communications de données fiables sur les réseaux de radiocommunication par paquets, ont pris en compte les leçons tirées du protocole NCP (Networking Control Protocol), puis ont créé la nouvelle génération du protocole TCP (Transmission Control Protocol), le protocole standard utilisé aujourd'hui sur Internet.
Dans les premières versions de cette technologie, il n'y avait qu'un seul protocole central, qui était nommé TCP. Et en fait, ces lettres ne signifiaient même pas ce qu'elles signifient aujourd'hui Protocole de contrôle de transmission, mais ils étaient pour le Programme de contrôle de transmission. La première version de ce précurseur du TCP moderne a été écrite en 1973, puis révisée et documentée formellement dans la RFC 675, Spécification du programme de contrôle de transmission Internet de décembre 1974.
Pendant le développement de TCP, Cerf et Kahn ont utilisé les concepts de CYCLADES, un réseau français de commutation de paquets, conçu et dirigé en 1973 par Louis Pouzin. Il a été développé pour explorer des alternatives à la conception d'ARPANET et pour soutenir la recherche sur les réseaux en général. CYCLADES a été le premier réseau à rendre les hôtes responsables de la livraison fiable des données, plutôt que le réseau lui-même, en utilisant des datagrammes non fiables (Pouzin a inventé le terme datagramme, en combinant les mots données et Telegram) et les mécanismes de protocole de bout en bout associés.
Le TCP/IP est devenu le protocole de communication standard d'Internet, permettant aux ordinateurs numériques de communiquer sur de longues distances. Internet est un réseau à commutation de paquets, dans lequel l'information est découpée en petits paquets, envoyés individuellement par de nombreux itinéraires différents en même temps, puis réassemblés à l'extrémité réceptrice. Le TCP est le composant qui collecte et réassemble les paquets de données, tandis que l'IP est responsable de s'assurer que les paquets sont envoyés à la bonne destination. Le TCP/IP a été développé dans les années 1970 et adopté comme norme de protocole pour ARPANET (le précurseur d'Internet) en 1983.
Formation Wireshark de 5 jours : Formation de 5 jours – TCP/IP Analysis and Troubleshooting with Wireshark
Quel est l'état actuel de la suite des protocoles Internet (communément appelée TCP/IP) ?
Il s'agit de l'ensemble des protocoles de communication utilisés pour Internet et d'autres réseaux similaires. Il tire son nom de deux des protocoles les plus importants qu'il contient : le protocole de contrôle de transmission (TCP) et le protocole Internet (IP), qui ont été les deux premiers protocoles de réseau définis dans cette norme. Le réseau IP d'aujourd'hui représente la synthèse de plusieurs développements qui ont commencé à évoluer dans les années 1960 et 1970, à savoir Internet et les réseaux locaux (LAN), qui ont émergé du milieu à la fin des années 1980, ainsi que l'avènement du World Wide Web au début des années 1990.
La conception du réseau comprenait la reconnaissance qu'il devait fournir uniquement les fonctions de transmission et de routage efficaces du trafic entre les nœuds d'extrémité et que toute autre intelligence devait être située à la périphérie du réseau, dans les nœuds d'extrémité. En utilisant une conception simple, il est devenu possible de connecter presque n'importe quel réseau à l'ARPANet, indépendamment de leurs caractéristiques locales. Un adage populaire veut que TCP/IP, le produit final du travail de Cerf et Kahn, fonctionne sur deux boîtes de conserve et une ficelle.
Un ordinateur ou un appareil appelé routeur (un nom changé de passerelle pour éviter toute confusion avec d'autres types de passerelles) est doté d'une interface vers chaque réseau et achemine les paquets dans les deux sens entre eux. Les exigences relatives aux routeurs sont définies dans la RFC 1812.
La DARPA a ensuite passé un contrat avec BBN Technologies, l'Université de Stanford et l'University College de Londres pour développer des versions opérationnelles du protocole sur différentes plates-formes matérielles. Quatre versions ont été développées : TCP v1, TCP v2, une division en TCP v3 et IP v3 au printemps 1978, puis la stabilité avec TCP/IP v4 — le protocole standard toujours utilisé aujourd'hui sur Internet.
En 1975, un test de communication TCP/IP à deux réseaux a été réalisé entre Stanford et l'University College London (UCL). En novembre 1977, un test TCP/IP à trois réseaux a été mené entre des sites aux États-Unis, au Royaume-Uni et en Norvège. Plusieurs autres prototypes TCP/IP ont été développés dans de nombreux centres de recherche entre 1978 et 1983. La migration d'ARPANet vers TCP/IP s'est officiellement achevée le 1er janvier 1983, lorsque les nouveaux protocoles ont été activés de manière permanente.
En mars 1982, le département de la Défense des États-Unis a déclaré TCP/IP comme la norme pour tous les réseaux informatiques militaires. En 1985, l'Internet Architecture Board a organisé un atelier de trois jours sur TCP/IP destiné à l'industrie informatique, auquel ont assisté 250 représentants de fournisseurs, promouvant le protocole et favorisant son utilisation commerciale croissante.
La suite des protocoles Internet, comme de nombreuses suites de protocoles, peut être vue comme un ensemble de couches. Chaque couche résout un ensemble de problèmes impliquant la transmission de données et fournit un service bien défini aux protocoles des couches supérieures en s'appuyant sur les services de certaines couches inférieures. Les couches supérieures sont logiquement plus proches de l'utilisateur et traitent des données plus abstraites, s'appuyant sur les protocoles des couches inférieures pour traduire les données en formes qui pourront éventuellement être transmises physiquement.
Le modèle TCP/IP se compose de quatre couches, tel qu'il est décrit dans la RFC 1122. De la plus basse à la plus haute, ce sont : la couche liaison, la couche internet, la couche transport et la couche application. Il convient de noter que ce modèle n'a pas été conçu pour être un modèle de référence rigide dans lequel les nouveaux protocoles doivent s'intégrer pour être acceptés comme norme.
Presque tous les systèmes d'exploitation utilisés aujourd'hui, y compris tous les systèmes grand public, intègrent une implémentation TCP/IP.
Formation Wireshark de 5 jours : Formation de 5 jours – TCP/IP Analysis and Troubleshooting with Wireshark
Source
www.history-computer.com
Encyclopaedia Britannica www.britannica.com/technology/TCP-IP