La historia de TCP/IP

El protocolo de red más popular del mundo, el conjunto de protocolos TCP/IP, fue diseñado en la década de 1970 por dos científicos de DARPA —Vint Cerf y Bob Kahn, las personas más a menudo llamadas los padres de Internet.

En la primavera de 1973, comenzaron realizando investigaciones sobre comunicaciones de datos confiables a través de redes de radio de paquetes, tuvieron en cuenta las lecciones aprendidas del Protocolo de Control de Red y luego crearon la siguiente generación del Protocolo de Control de Transmisión (TCP), el protocolo estándar utilizado en Internet hoy en día.

En las primeras versiones de esta tecnología, solo había un protocolo central, que se llamaba TCP. Y, de hecho, estas letras ni siquiera significaban lo que significan hoy. Protocolo de Control de Transmisión, pero eran para el Programa de Control de Transmisión. La primera versión de este predecesor del TCP moderno se escribió en 1973, y luego se revisó y documentó formalmente en el RFC 675, Especificación del Programa de Control de Transmisión de Internet de diciembre de 1974.

Durante el desarrollo de TCP, Cerf y Kahn utilizaron los conceptos de CYCLADES, una red de conmutación de paquetes francesa, diseñada y dirigida en 1973 por Louis Pouzin. Fue desarrollada para explorar alternativas al diseño de ARPANET y para apoyar la investigación en redes en general. CYCLADES fue la primera red en hacer que los hosts fueran responsables de la entrega confiable de datos, en lugar de la red misma, utilizando datagramas no confiables (Pouzin acuñó el término datagrama, combinando las palabras datos y Telegram) y los mecanismos de protocolo de extremo a extremo asociados.

TCP/IP se convirtió en el protocolo estándar de comunicación de internet que permite a las computadoras digitales comunicarse a largas distancias. Internet es una red de conmutación de paquetes, en la cual la información se divide en pequeños paquetes, se envía individualmente por muchas rutas diferentes al mismo tiempo y luego se vuelve a ensamblar en el extremo receptor. TCP es el componente que recopila y vuelve a ensamblar los paquetes de datos, mientras que IP se encarga de asegurar que los paquetes se envíen al destino correcto. TCP/IP se desarrolló en la década de 1970 y se adoptó como el estándar de protocolo para ARPANET (el predecesor de internet) en 1983.

Capacitación en Wireshark de 5 Días: Capacitación de 5 días – TCP/IP Analysis and Troubleshooting with Wireshark

¿Cuál es el estado actual del conjunto de protocolos de Internet (comúnmente conocido como TCP/IP)?

Es el conjunto de protocolos de comunicación utilizados para Internet y otras redes similares. Debe su nombre a dos de los protocolos más importantes que lo componen: el Protocolo de Control de Transmisión (TCP) y el Protocolo de Internet (IP), que fueron los dos primeros protocolos de red definidos en este estándar. La creación de redes IP actual representa una síntesis de varios desarrollos que comenzaron a evolucionar en las décadas de 1960 y 1970, a saber, Internet y las LAN (redes de área local), que surgieron a mediados y finales de la década de 1980, junto con la llegada de la World Wide Web a principios de la década de 1990.

El diseño de la red incluía el reconocimiento de que debía proporcionar únicamente las funciones de transmitir y enrutar eficientemente el tráfico entre nodos finales y que toda la demás inteligencia debía ubicarse en el borde de la red, en los nodos finales. Utilizando un diseño simple, fue posible conectar casi cualquier red a ARPANet, independientemente de sus características locales. Un dicho popular sostiene que TCP/IP, el producto final del trabajo de Cerf y Kahn, funcionará sobre dos latas y una cuerda.

Una computadora o dispositivo llamado enrutador (un nombre cambiado de puerta de enlace para evitar confusión con otros tipos de puertas de enlace) cuenta con una interfaz para cada red y reenvía paquetes de un lado a otro entre ellas. Los requisitos para los enrutadores se definen en el RFC 1812.

DARPA contrató entonces a BBN Technologies, a la Universidad de Stanford y al University College de Londres para desarrollar versiones operativas del protocolo en diferentes plataformas de hardware. Se desarrollaron cuatro versiones: TCP v1, TCP v2, una división en TCP v3 e IP v3 en la primavera de 1978, y luego la estabilidad con TCP/IP v4, el protocolo estándar que todavía se utiliza hoy en Internet.

En 1975, se realizó una prueba de comunicación TCP/IP de dos redes entre Stanford y el University College London (UCL). En noviembre de 1977, se llevó a cabo una prueba TCP/IP de tres redes entre sitios en EE. UU., el Reino Unido y Noruega. Se desarrollaron varios otros prototipos de TCP/IP en múltiples centros de investigación entre 1978 y 1983. La migración de ARPANet a TCP/IP se completó oficialmente el 1 de enero de 1983, cuando los nuevos protocolos se activaron permanentemente.

En marzo de 1982, el Departamento de Defensa de EE. UU. declaró TCP/IP como el estándar para todas las redes informáticas militares. En 1985, la Junta de Arquitectura de Internet celebró un taller de tres días sobre TCP/IP para la industria informática, al que asistieron 250 representantes de proveedores, promoviendo el protocolo y conduciendo a su creciente uso comercial.

El conjunto de protocolos de Internet, como muchos conjuntos de protocolos, puede verse como un conjunto de capas. Cada capa resuelve un conjunto de problemas relacionados con la transmisión de datos y proporciona un servicio bien definido a los protocolos de las capas superiores basándose en el uso de servicios de algunas capas inferiores. Las capas superiores están lógicamente más cerca del usuario y manejan datos más abstractos, y dependen de los protocolos de las capas inferiores para traducir los datos a formas que eventualmente puedan transmitirse físicamente.

El modelo TCP/IP consta de cuatro capas, tal como se describe en el RFC 1122. De menor a mayor, estas son: la capa de enlace, la capa de internet, la capa de transporte y la capa de aplicación. Cabe señalar que este modelo no pretendía ser un modelo de referencia rígido en el que los nuevos protocolos deban encajar para ser aceptados como estándar.

Casi todos los sistemas operativos en uso hoy en día, incluidos todos los sistemas destinados al consumidor, incluyen una implementación de TCP/IP.

Capacitación en Wireshark de 5 Días: Capacitación de 5 días – TCP/IP Analysis and Troubleshooting with Wireshark

Fuente: 
www.history-computer.com
Enciclopedia Británica www.britannica.com/technology/TCP-IP